NOTE

Allowed memory size of xxx bytes exhausted with WordPress on Debian

My Debian Squeeze host started having trouble performing WordPress 3.5 core or plugin updates – in the error logs, I’d see messages like:

Allowed memory size of xxx bytes exhausted

After scouring the internet, attempting to adjust memory limits on php.ini, apache, etc, I eventually discovered the solution was to add:

USE_ZEND_ALLOC=0

to /etc/apache2/envvars. Problem solved.


If you found this useful, please share it and follow me on Twitter - I'd love to connect ;)


Discuss